Jump to content
Atavism Online

Can't get server to connect to eth0


jayalter
 Share

Recommended Posts

I followed the directions in setting up the CentOS VM exactly as were detailed.  However even after having set the IP and gateway for eth0 when I issue the "service network restart" command I get the following output:
image.png.b336f7e0aeab14d9a99a76a904da46c4.png

Of course my eth0 IS present as I am able to access the internet as normal via Windows.  Here is the settings for my eth0 in VirtualBox:
image.png.0774c431ac7c56c85751bf97e892656a.png

Any help would be GREATLY appreciated!  I'm stuck until I can get this part working!  Thanks in advance!

 

Link to comment
Share on other sites

4 minutes ago, Martin (Dragonsan) said:

Command is incorrect, please use the exact command I sent you.

Ok I did it again using the -a.  Here are the results.  For some reason there is an eth2 and an eth3 but no eth0 or eth1.  Not sure why or which is the one for my ethernet adapter?

image.png.26a24bf1907ec8adf52a2f2b6a3962c3.png

Link to comment
Share on other sites

So, you have interfaces eth2 and eth3, probably during import you haven't selected option to include all network adapters

image.png

To fix this you have to adjust your network adapter configuration file in this case 

nano /etc/sysconfig/networking/devices/ifcfg-eth2

or

nano /etc/sysconfig/networking/devices/ifcfg-eth3

depending which interface is your main one (that you set to your bridged network adapter), probably eth2, set network settings there and proceed further with the installation along with the documentation https://unity.wiki.atavismonline.com/project/atavism-virtual-machine/

Link to comment
Share on other sites

1 minute ago, Martin (Dragonsan) said:

So, you have interfaces eth2 and eth3, probably during import you haven't selected option to include all network adapters

image.png

To fix this you have to adjust your network adapter configuration file in this case 

nano /etc/sysconfig/networking/devices/ifcfg-eth2

or

nano /etc/sysconfig/networking/devices/ifcfg-eth3

depending which interface is your main one (that you set to your bridged network adapter), probably eth2, set network settings there and proceed further with the installation along with the documentation https://unity.wiki.atavismonline.com/project/atavism-virtual-machine/

Perfect!  Thats the solution I was hoping to find!  I'll give that a try!  Thanks so so much!

Link to comment
Share on other sites

3 minutes ago, Martin (Dragonsan) said:

Great, let me know if you will need further assistance.

Ok so I did what you suggested.  I set the settings that I had originally set in eth0 to eth2.  I issued "service network restart" after saving eth2 and this is the result:
image.png.7af29c5ceec47ab9e7895e355caa05f5.png

I would appear while  "sudo ifconfig -a" shows there is eth2 and eth3 the service network restart doesn't see those configs  and / or devices??

 

Link to comment
Share on other sites

4 minutes ago, jayalter said:

Ok so I did what you suggested.  I set the settings that I had originally set in eth0 to eth2.  I issued "service network restart" after saving eth2 and this is the result:
image.png.7af29c5ceec47ab9e7895e355caa05f5.png

I would appear while  "sudo ifconfig -a" shows there is eth2 and eth3 the service network restart doesn't see those configs  and / or devices??

 

BTW, I tried the setting up the Ubuntu VM as well.  It had no problem with setting up the ETH devices, HOWEVER, a the FTP part the connect to 192.168.254.102 simply times out and never connects.  I have no idea why or what needs to be done there.  I'm open to fixing either VM as long as I can get one working!

Link to comment
Share on other sites

18 minutes ago, jayalter said:

BTW, I tried the setting up the Ubuntu VM as well.  It had no problem with setting up the ETH devices, HOWEVER, a the FTP part the connect to 192.168.254.102 simply times out and never connects.  I have no idea why or what needs to be done there.  I'm open to fixing either VM as long as I can get one working!

There is no FTP but SFTP which is FTP over SSH, so you should be able to use simple winscp with SFTP settings and SSH credentials: root/atavism.

 

26 minutes ago, jayalter said:

Ok so I did what you suggested.  I set the settings that I had originally set in eth0 to eth2.  I issued "service network restart" after saving eth2 and this is the result:
image.png.7af29c5ceec47ab9e7895e355caa05f5.png

I would appear while  "sudo ifconfig -a" shows there is eth2 and eth3 the service network restart doesn't see those configs  and / or devices??

 

You can try to type in the console

ifconfig eth2 up

and the same for eth3 accordingly. It should bring your interface with your settings up. If you don't have eth0 nor eth1, you can remove these two configuration files related to these interfaces.

Link to comment
Share on other sites

34 minutes ago, Martin (Dragonsan) said:

There is no FTP but SFTP which is FTP over SSH, so you should be able to use simple winscp with SFTP settings and SSH credentials: root/atavism.

 

You can try to type in the console

ifconfig eth2 up

and the same for eth3 accordingly. It should bring your interface with your settings up. If you don't have eth0 nor eth1, you can remove these two configuration files related to these interfaces.

Well I tried the "ifconfig eth2 up" command and it did absolutely nothing.  So that was a fail.  As for your response about using SFTP Yes I left it set on SFTP and used the proper creds.  All it does is sit there "searching for server...." which is never found and I eventually get a "timed out" message.  I'm wondering if these VM's can't handle new motherboards with the newer Intel 2.5G Ethernet adapters.  Both the CentOS and the Ubuntu VM's have problems initializing the interfaces to the point that neither works.  It's a show stopper for me and without this I will have hit a blocker that will keep me from using the product.  Is there a mac version of the server?  I could try installing that on one of my macbook pro's and see if it works.  Otherwise I'm at a total loss on how to continue.

Link to comment
Share on other sites

ifconfig eth2 up

command won't return anything. It should just activate eth2 interface, which then should be visible using

ifconfig -a

Atavism can be installed in any environment. VM is just one of the installation method, but you can use any Linux or Mac to install it directly within the system using Custom Linux installation guide https://unity.wiki.atavismonline.com/project/installation/

Youi can also use any cloud solution, but of course, it will cause some additional expenses.

If you prefer to use VM, we can schedule a TeamViewer session during which we can help you to set your VM with Atavism.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recommended Cloud Solution


    northnetworking.com

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.