Jump to content
Atavism Online

Has anyone seen this on the log-in screen?


Flapman
 Share

Recommended Posts

Hello, have you setup your Master Server in the Login scene -> AtavismCore game object to point your server installation?

Can you tell me what is your server installation method, like are you using Atavism Windows Manager, custom Linux or maybe a cloud server?

Have you imported any third party packages into your project or maybe turned on i2localization integration?

Link to comment
Share on other sites

Hi Martin,

Thanks for the quick reply.   Yes, to the first part.  See my screenshot.

The Install method is the Atavism Windows Manager.

Yes, I have activated the i2localization in the Online Editor settings.  Should I not have?  I will likely want to make the game localized based on location (mainly in NA such as English, French and Spanish).

As far as other packages, yes.  I have Game Creator2 (which I have removed to test out Atavism) and PBR Infinity's Human Character Package.

Screen Shot 2022-11-16 at 8.53.24 AM.png

Link to comment
Share on other sites

Ok. Is this installation on the same machine as your Unity? If so, then for the test try to set the IP to 127.0.0.1 in both Atavism Windows Manager as well as here in the Master Server inside Unity. I'm suspecting that the issue can be due to one of these elements:

1. Port that you set in the Atavism Windows Manager doesn't match the one in Unity. In this case, 9005, and 9010 are the default ones. Sometimes it's required to change 9010 to 9011 for example, because 9010 is in use in windows by default.

2. Firewall is blocking connections, and the above change to 127.0.0.1 will show us in which direction we should go further with this.

As for the localization, yes you can enable it, but do you have i2localization in your project?

Link to comment
Share on other sites

52 minutes ago, Martin (Dragonsan) said:

Ok. Is this installation on the same machine as your Unity? If so, then for the test try to set the IP to 127.0.0.1 in both Atavism Windows Manager as well as here in the Master Server inside Unity. I'm suspecting that the issue can be due to one of these elements:

The Window Manager is on a separate machine on my network.   I work on my laptop and run the server on a different machine.  I pulled the IP address from my ipconfig on the server machine.

Quote

As for the localization, yes you can enable it, but do you have i2localization in your project?

Yes, I have it in my project.

Link to comment
Share on other sites

Quote

You can try to install the server software on the same machine, or you can send me server logs in private to ensure that it's the firewall.

I can try that but let me see if I can send you those server logs first.  Ideally, I want to be able to run it separately, especially if I can make my world work in Atavism.  I want to run the world on an ongoing basis via a server that is up.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recommended Cloud Solution


    northnetworking.com

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.