Jump to content
Jaroe

Why is setting this up such a chore?

Recommended Posts

I first purchased this product about a year ago. And after following the directions to a tee (using the AtavismUbuntu Virtual Machine) and searching through the forums for answers--that  I feel should be covered by the original instructions--I was able to get a project started and was able to create a character and enter the game. Since upgrading to Atavism X, I have been able to get into the actual game a grand total of three time. (I mention this to point out that by some miracle, I am able to get in.) Upon installing the UMA integration into Unity, I have gone back and forth between "Cannot connect to Authentication Server and Cannot connect to Master Server." I have uninstalled EVRYTHING along the way, entering everything the exact same way I did when I first got this software to work. I have re-read the instructions, followed the videos and searched the forums for people having similar issues. 

This is a lot of money to throw away in a product that, I feel, should be much easier to setup and troubleshoot. 

I am tired of searching forums to find simple answers when I know that this used to work. I used to have UMA working just fine. 

I've got days ticking away on my license and I just want my money back.

Sorry if this doesn't belong in the forums, but I didn't see any other place to air my grievances with this product. 

 

This is my latest error:

 

Exception connecting to rdp master server: System.TimeoutException: The operation has timed out.
  at Atavism.RdpClient.Connect (System.Net.IPEndPoint remoteEP, System.Int32 millisecondsTimeout) [0x00039] in <fc56ccf0eb7444e9b349fa107101ed04>:0 
  at Atavism.RdpMessageHandler..ctor (System.Net.IPEndPoint remote, System.Int32 millisecondsTimeout) [0x00082] in <fc56ccf0eb7444e9b349fa107101ed04>:0 
  at Atavism.RdpMasterMessageHandler..ctor (System.Net.IPEndPoint remote, System.Collections.Generic.Dictionary`2[TKey,TValue] worldServerMap) [0x00000] in <fc56ccf0eb7444e9b349fa107101ed04>:0 
  at Atavism.AtavismNetworkHelper.RdpMasterConnect (System.String hostname, System.Int32 port) [0x00016] in <fc56ccf0eb7444e9b349fa107101ed04>:0 
UnityEngine.Debug:LogError(Object)
Atavism.AtavismLogger:LogError(Object)
Atavism.AtavismNetworkHelper:RdpMasterConnect(String, Int32)
Atavism.AtavismNetworkHelper:ResolveWorld(LoginSettings)
Atavism.AtavismLoginHelper:ResolveWorld()
Atavism.AtavismLoginHelper:LoginMaster(String, Int32&)
Atavism.<MasterLoginAsync>d__80:MoveNext()
UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
Atavism.AtavismClient:Login(String, String, Dictionary`2)
Atavism.LoginControll

Share this post


Link to post
Share on other sites
13 hours ago, Jaroe said:

I first purchased this product about a year ago. And after following the directions to a tee (using the AtavismUbuntu Virtual Machine) and searching through the forums for answers--that  I feel should be covered by the original instructions--I was able to get a project started and was able to create a character and enter the game. Since upgrading to Atavism X, I have been able to get into the actual game a grand total of three time. (I mention this to point out that by some miracle, I am able to get in.) Upon installing the UMA integration into Unity, I have gone back and forth between "Cannot connect to Authentication Server and Cannot connect to Master Server." I have uninstalled EVRYTHING along the way, entering everything the exact same way I did when I first got this software to work. I have re-read the instructions, followed the videos and searched the forums for people having similar issues. 

This is a lot of money to throw away in a product that, I feel, should be much easier to setup and troubleshoot. 

I am tired of searching forums to find simple answers when I know that this used to work. I used to have UMA working just fine. 

I've got days ticking away on my license and I just want my money back.

Sorry if this doesn't belong in the forums, but I didn't see any other place to air my grievances with this product. 

 

This is my latest error:

 

Exception connecting to rdp master server: System.TimeoutException: The operation has timed out.
  at Atavism.RdpClient.Connect (System.Net.IPEndPoint remoteEP, System.Int32 millisecondsTimeout) [0x00039] in <fc56ccf0eb7444e9b349fa107101ed04>:0 
  at Atavism.RdpMessageHandler..ctor (System.Net.IPEndPoint remote, System.Int32 millisecondsTimeout) [0x00082] in <fc56ccf0eb7444e9b349fa107101ed04>:0 
  at Atavism.RdpMasterMessageHandler..ctor (System.Net.IPEndPoint remote, System.Collections.Generic.Dictionary`2[TKey,TValue] worldServerMap) [0x00000] in <fc56ccf0eb7444e9b349fa107101ed04>:0 
  at Atavism.AtavismNetworkHelper.RdpMasterConnect (System.String hostname, System.Int32 port) [0x00016] in <fc56ccf0eb7444e9b349fa107101ed04>:0 
UnityEngine.Debug:LogError(Object)
Atavism.AtavismLogger:LogError(Object)
Atavism.AtavismNetworkHelper:RdpMasterConnect(String, Int32)
Atavism.AtavismNetworkHelper:ResolveWorld(LoginSettings)
Atavism.AtavismLoginHelper:ResolveWorld()
Atavism.AtavismLoginHelper:LoginMaster(String, Int32&)
Atavism.<MasterLoginAsync>d__80:MoveNext()
UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
Atavism.AtavismClient:Login(String, String, Dictionary`2)
Atavism.LoginControll

Hello Jaroe. 

This is totally fine, we will move this topic to the support section after we will find and resolve the issue.

Your error log indicates like your master server is not running at all, or it's behind a firewall, by default port 9010. The port can be set in the auth.properties configuration file on the server, and it should be set accordingly on the client site in the Login scene -> AtavismCore.

Can you provide me your log files from the server? The most important are authentication.log from the atavism_server/logs/master directory, and this should indicate what is wrong with it, and the second can be related to the login process login_manager.log from atavism_server/logs/world directory.

You can send them in private as they contain sensitive information.

We can also schedule remote hands support (Teamviewer) for you, so we could resolve this issue directly with you in realtime.

You can contact with me here on if you prefer realtime contact you can use our discord server https://discord.gg/z95htJA

Share this post


Link to post
Share on other sites

I have tested everything with my Firewall disabled. My master Server Rdp Port is set to 9010. The Master Server Tcp Port is set to 9005. My Default Master Sever is set to 192.168.1.102 and I am able to successfully ping it from a command prompt from any PC on my network. 

 

Also, I use the Virtual Box because I have never been able to get Atavism Manager to connect. No matter what I try, I can not get the World Server Button to go green. The Install Button stays grayed out when I add the atavism_server_10.0.0.zip file.

Edited by Jaroe
more info

Share this post


Link to post
Share on other sites
47 minutes ago, Jaroe said:

I have tested everything with my Firewall disabled. My master Server Rdp Port is set to 9010. The Master Server Tcp Port is set to 9005. My Default Master Sever is set to 192.168.1.102 and I am able to successfully ping it from a command prompt from any PC on my network. 

 

Also, I use the Virtual Box because I have never been able to get Atavism Manager to connect. No matter what I try, I can not get the World Server Button to go green. The Install Button stays grayed out when I add the atavism_server_10.0.0.zip file.

Controls in the Atavism Editor are only for the Virtual Machines. Atavism Windows Manager has it's own controls inside the app.

Can we schedule remote hands session for tomorrow? We should be able to track down the issue and fix it within 15-30 minutes depending on the complexity. I'll be available again in around 7 hours. You will be able to see whole troubleshooting process.

Share this post


Link to post
Share on other sites
1 hour ago, Jaroe said:

Are you referring to the VBox.log file? And how should I send it to you?

 

No, i was referring to the Atavism Server logs. On the Virtual Machine they should be in the /root/atavism_server/logs directory, you can download them using winscp, pack them using zip, 7z, rar, or any other packer and send it to me using direct message on the forum, or to support@atavismonline.com.

Share this post


Link to post
Share on other sites

I am actually about to get offline myself.  I just sent over the log files but have other work I need to get back to. It is almost 10:00 pm. I likely won't be able to make it back on until 6:00 pm my time tomorrow. But I will try to get set up on the Discord channel. 

 

Share this post


Link to post
Share on other sites

Ok, I uninstalled and reinstalled EVERYTHING. I was able to get Atavism Manager to work with all servers turning green. I even made it to the damned Character selection. I Set my class and named the old guy. Guess what I got. "Could not find Character Template for the Race and Class specified." I stopped Unity and gave it another try. "Cannot connect to the World Server." What the HELL. Atavism manager still says everything is running. How can you charge this much for a product so obviously broken?

Share this post


Link to post
Share on other sites

Seriously, this is a pain in my ass. I downloaded and ran Atavism X(10.0.0) Unity with Demo 1/1 (not divided), not the CORE version. My Player Character Setup is Blank, with no option to add anything. Just clicking the button gives me a host of errors, starting with : MySql.Data.MySqlClient.MySqlException: Table 'world_content.factions' doesn't exist
  at MySql.Data.MySqlClient.MySqlStream.ReadPacket () [0x00000] in <filename unknown>:0 
  at MySql.Data.MySqlClient.NativeDriver.GetResult (System.Int32& affectedRow, System.Int64& insertedId) [0x00000] in <filename unknown>:0 
UnityEngine.Debug:LogError(Object)
Atavism.DatabasePack:LoadData(String, String) (at Assets/Dragonsan/AtavismEditor/Editor/EditorCore/Libraries/DatabasePack.cs:398)
Atavism.ServerCharacter:LoadFactionOptions() (at Assets/Dragonsan/AtavismEditor/Editor/Plugins/ServerCharacter.cs:175)
Atavism.ServerCharacter:DrawEditor(Rect, Boolean) (at Assets/Dragonsan/AtavismEditor/Editor/Plugins/ServerCharacter.cs:795)
Atavism.AtavismDatabaseFunction:Draw(Rect) (at Assets/Dragonsan/AtavismEditor/Editor/AtavismDatabaseFunction.cs:223)
Atavism.AtavismUnity:OnGUI() (at Assets/Dragonsan/AtavismEditor/Editor/EditorCore/AtavismUnity.cs:361)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

The same goes for Quests and Skills.

If it's not one thing with this worthless product, it's another. 

Share this post


Link to post
Share on other sites
8 hours ago, Jaroe said:

Ok, I uninstalled and reinstalled EVERYTHING. I was able to get Atavism Manager to work with all servers turning green. I even made it to the damned Character selection. I Set my class and named the old guy. Guess what I got. "Could not find Character Template for the Race and Class specified." I stopped Unity and gave it another try. "Cannot connect to the World Server." What the HELL. Atavism manager still says everything is running. How can you charge this much for a product so obviously broken?

Could not find Character Template occurs where you are using Atavism Core version on the server (by default we are recommending to use demo, which has lots of examples and configurations). Core version was prepared based on the community requests, to allow very clean installation for advanced users. Core version requires two additional steps to runt it.

1. You need to create an instance with the name of your map.

2. You need to create character templates to let the server create your character.

Both can be done in Atavism Editor in Unity,, ans it's described briefly here in the "Hot to start with Atavism" documentation https://wiki.atavismonline.com/project/how-to-start-with-atavism/.

I can assure you that the product is not broken at all, but there must be an issue in the configuration. As I said. We can organize it, you will pick the method and let's configure it step by step, or much faster way is Teamviewer, where instead of days for message exchanging, you can do the installation, or we can troubleshoot and find the cause of the issue of your current installation as well. When you are starting the installation from scratch, then you are covering the previous issue instead of finding the cause. Choose the installation method of your choice and we will process it with you step by step while answering all your questions.

6 hours ago, Jaroe said:

Seriously, this is a pain in my ass. I downloaded and ran Atavism X(10.0.0) Unity with Demo 1/1 (not divided), not the CORE version. My Player Character Setup is Blank, with no option to add anything. Just clicking the button gives me a host of errors, starting with : MySql.Data.MySqlClient.MySqlException: Table 'world_content.factions' doesn't exist
  at MySql.Data.MySqlClient.MySqlStream.ReadPacket () [0x00000] in <filename unknown>:0 
  at MySql.Data.MySqlClient.NativeDriver.GetResult (System.Int32& affectedRow, System.Int64& insertedId) [0x00000] in <filename unknown>:0 
UnityEngine.Debug:LogError(Object)
Atavism.DatabasePack:LoadData(String, String) (at Assets/Dragonsan/AtavismEditor/Editor/EditorCore/Libraries/DatabasePack.cs:398)
Atavism.ServerCharacter:LoadFactionOptions() (at Assets/Dragonsan/AtavismEditor/Editor/Plugins/ServerCharacter.cs:175)
Atavism.ServerCharacter:DrawEditor(Rect, Boolean) (at Assets/Dragonsan/AtavismEditor/Editor/Plugins/ServerCharacter.cs:795)
Atavism.AtavismDatabaseFunction:Draw(Rect) (at Assets/Dragonsan/AtavismEditor/Editor/AtavismDatabaseFunction.cs:223)
Atavism.AtavismUnity:OnGUI() (at Assets/Dragonsan/AtavismEditor/Editor/EditorCore/AtavismUnity.cs:361)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

The same goes for Quests and Skills.

If it's not one thing with this worthless product, it's another. 

Based on this additional information it seems, that you have some other MySQL/MariaDB installation within your system or you didn't provide database credentials in the Atavism Editor -> Database settings. In both cases, options must be empty, as you cannot access the database.

When you are providing an atavism server zip file in the Atavism Windows Manager, you have two fields in it (DB Username and DB Password). By default, Atavism Manager comes with a binary version of MariaDB, but if you have your database installed within your system, and it's running on the default 3306 port, then you won't be able to start our database, and you have to change these credentials to your database installation.

We need to start from the beginning, because instead of resolving the issue, you are switching platform, and other issues occurs on your end, so I highly recommend you to use our remote hands (Teamviewer) session, where during it, we will together troubleshoot your issues, and I'll show you how to fix them (I can say that all of them are in most cases related to the misconfiguration). After such a session, I'm sure that you say, "it's not possible that it was such a small, simple thing".

I have to say that we have over 5000 clients, and at least hundreds are using both VM and Atavism Manager without issues. 

The last error you posted indicates that Atavism Editor cannot access the database, and to troubleshoot it, you can:
1. Check if credentials are configured properly.
2. Check if the databases (admin, atavism, master, world_content) exist.
3. Repeat installation procedure and verify that it was correctly completed.
I would do these steps and more during such support remote session. If you don't want to make a Teamviewer session, then we can do a standard screen share, where you will do all the tasks, and I'll just guide you. It will take a bit longer, but it's still possible.
Using Teamviewer I can show you step by step installation for both methods VM and Atavism Manager and I'm pretty sure that it will work within minutes.

Share this post


Link to post
Share on other sites

Hello, I haven't heard from you for a while.

My offer is to:

1. Help you set your server using Teamviewer (preferable) (In most cases issue is related to misconfiguration, and it takes me average 5 minutes to track it down and resolve it based on your feedback) or screen share (this can take longer, as I'll be a viewer only).

2. Choose one of the installation methods, and let's resolve all the issues you will have. In this case, I'll ask you to contact me in private in some cases where I'll need some of your logs to track down potential issues. This can be done using the forum, or realtime support channel (discord https://discord.gg/z95htJA).

I'm sorry that you are experiencing such issues, but even this week we have more than 10 new clients, and it works for all of them with some adjustments like incorrect IP address or database password defined in the configuration file.

Independently on the choice and no matter if we will resolve your issues (and I'm sure we will, as there is no single installation which we couldn't process) I can order a refund for you.

Share this post


Link to post
Share on other sites

I agree with Killersan that its not ATAVISM. I spent a few days tinkering as I never done this type set up. Handed it over to my 28 year old son who has a degree in programming and an A+ certification (translates to Can Follow Directions and Exhibit Patients). I took an old Lenovo laptop with 4Gig DDR2 memory, wiped it and installed Ubuntu 2016 Server. I turned it over to Jason. He had ATAVISM up and running before I could finish cooking dinner. Less than 45 minutes.

I am here because I was looking for a resolution to the "Could not find Character Template for the Race and Class specified."  I purchased Faces Volume 1 and 2 from Will B Game Art and am trying to get the Orc male and female hybrids into ATAVISM. My son got in the Human male/female and the Elf male/female races, and got in the Orc races from ATAVISM successfully the other day, but he is asleep and has to get up at 4 AM to go to work. I assume it is me as we have been using ATAVISM X On Site for over a week with other races (AMAZING!!! Product).

We were going to buy the Orc, Dwarf and Goblin races from ATAVISM when On Sale for $25 each but I swear going from the shopping to the checkout, the sale ended and the price was full again. We did not have $150, so we went and purchased the Faces vol. 1 and vol. 2 from Will B Game Art as they had a 60% off coupon code. Hopefully we can squeeze out $50 to buy the Dwarf race pack in two weeks and then buy one race pack each month after that. ATAVISM has been working with only issues we cause by not following directions. As far as the "Could not find Character Template for the Race and Class specified.", I obviously skipped something with this specific race and need to discover what it is and if I can not, I will let Jason do it sometime in the next couple days. So it is on to reading the wiki and watching YouTube Videos or let Jason have it tomorrow and I will work tonight on importing Animals from our Protofactor pack.

 

I found this ATAVISM video, so I think this is what I need to watch.

 

Edited to say that I was correct in assuming it was not Atavism but in fact was me forgetting something. After updating things like adding a race or tools, weapons, armor, jeweler or other, RESTART THE SERVER. When in doubt, REBOOT THE SERVER if restarting does not do it. If that does not fix it, then shut down the server and give the ram a chance to empty (30 seconds or so). Power it up, then log back in and Start The Server.

8-)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recommended Cloud Solution


    northnetworking.com

  • Discord Server: Atavism
    100

    • <Riot> Altimer
      <Riot> Altimer
    • Adaika
      Adaika
    • Aerich
      Aerich
    • APlusMods
      APlusMods
    • Aps
      Aps
    Join Us!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.